Intermittent Service Degradation

Incident Report for Greenshades Online

Resolved

The loading issue affecting Greenshades Benefits and Time Off has been fixed, and the affected systems are now operating normally. Thanks for your patience.
Posted Sep 12, 2026 - 20:11 EDT

Identified

We have identified the issue affecting some users on Greenshades Benefits and Time Off with loading failures. Our team is working on a resolution to this now, and we'll share an update here as soon as we have more information.
Posted Sep 11, 2026 - 14:00 EDT

Investigating

We are currently investigating loading failures affecting some users on Greenshades Benefits and Time Off. Our team is looking into this now, and we'll share an update here as soon as we have more information.
Posted Sep 11, 2026 - 13:40 EDT
This incident affected: Employee Services.