Intermittent Site Degradation

Incident Report for Greenshades Online

Resolved

This incident has been resolved and service is now fully restored.

We have implemented a change to prevent recurrence of this type of issue.
Posted Jul 20, 2026 - 10:17 EDT

Monitoring

Site performance has recovered. We are actively monitoring to confirm full resolution.
Posted Jul 20, 2026 - 09:38 EDT

Investigating

We've identified an issue affecting multiple services and products. We are actively investigating the cause and solution. Users may experience intermittent slowness.
Posted Jul 20, 2026 - 09:16 EDT
This incident affected: Single Sign On, Tax Service, Employee Services, Year End Forms, and Payroll.