Partial Service Outage Affecting Critical Products

Incident Report for Greenshades Online

Resolved

This incident has been resolved.

The root cause was identified as an issue with our event handler. After a full restart during the maintenance period, we are seeing proper operation on all products and services. We appreciate your patience and understanding during this time.
Posted Aug 12, 2025 - 22:44 EDT

Monitoring

All services are up and running. Things are looking good. We are monitoring for any additional issues.
Posted Aug 12, 2025 - 22:33 EDT

Update

To continue to address the issues and ensure full restoration of services, Greenshades Online will be under maintenance starting at 9:00 PM EDT and concluding by 12:00 AM EDT.

We appreciate your patience and understanding during this time. Our team is actively working to resolve the issue, and we will continue to provide updates as they become available.

Thank you for your continued support.
Posted Aug 12, 2025 - 21:05 EDT

Update

Upon further investigation, new issues have been discovered with Payroll products, specifically around payroll completion and Pay History (i.e. Check Printing).

PTS issues are currently expected to be resolved.
Posted Aug 12, 2025 - 17:34 EDT

Update

Remediation of underlying issues especially for users of Benefits, Timesheets, and/or Timesheets + Payroll product offerings.

Known outstanding issues still actively being addressed for PTS products.
Posted Aug 12, 2025 - 16:59 EDT

Identified

We’ve identified the root cause of the service disruption. An internal message queuing services is currently experiencing communication failures, which is affecting multiple connected components across our platform. Our engineering teams are actively working on a resolution and will continue to provide updates as progress is made.

Thank you for your continued patience.
Posted Aug 12, 2025 - 15:35 EDT

Investigating

We are currently experiencing a service disruption impacting several critical products. Our teams are actively working to restore full functionality and minimize any impact to users.

We appreciate your patience and will continue to provide updates as more information becomes available.
Posted Aug 12, 2025 - 15:05 EDT
This incident affected: Tax Service, Employee Services, and Payroll.