Pay History loading issues
Incident Report for Greenshades Online
Resolved
This incident has been resolved.
Posted Jun 23, 2022 - 13:16 EDT
Monitoring
We have identified the root cause of the issue and a fix has been released. We will continue to monitor however pay history is back to 100% operational.
Posted Jun 23, 2022 - 09:35 EDT
Update
We are continuing to investigate this issue.
Posted Jun 23, 2022 - 09:27 EDT
Investigating
Pay History (pay stub, direct deposit) access is experiencing slowness. Employees may experience long wait times while loading these documents.
Posted Jun 23, 2022 - 09:26 EDT
This incident affected: Employee Services.