Year End Forms Performance Degradation
Incident Report for Greenshades Online
Resolved
Response times have returned to normal. All Greenshades sites and services are functioning normally.
Posted Feb 07, 2023 - 00:47 EST
Monitoring
Response times are beginning to return to normal. Some users with specific internet providers may still experience slower response times until the issue is fully resolved. We are continuing to monitor and will update as necessary.
Posted Feb 07, 2023 - 00:18 EST
Identified
An outage with a large internet providers has cause issues connecting to downloadmyform.com. We are working with our internet provider to mitigate this issue and will provide updates as we have them.
Posted Feb 06, 2023 - 18:52 EST
This incident affected: Year End Forms.