We have resolved issues with login failures and slow load times affecting some users on Greenshades Online and Green Employee. Thank you for your patience while we worked through this.
Posted Sep 04, 2026 - 16:50 EDT
Monitoring
We have implemented a resolution for an issue with login failures and slow load times affecting some users on Greenshades Online and Green Employee. Our team is monitoring to ensure full resolution, and we'll share an update here as soon as we can.
Posted Sep 04, 2026 - 13:19 EDT
Identified
We have identified an issue with login failures and slow load times affecting some users on Greenshades Online and Green Employee. Our team implementing resolutions for this now, and we'll share an update here as soon as we can.
Posted Sep 04, 2026 - 13:11 EDT
Investigating
We are currently investigating login failures and slow load times affecting some users on Greenshades Online and Green Employee. Our team is looking into this now, and we'll share an update here as soon as we have more information.
Posted Sep 04, 2026 - 12:59 EDT
This incident affected: SMS for 2 Factor Authentication (Twilio SMS, Twilio SMS Toll-Free, North America, Twilio REST API) and Single Sign On, Tax Service, Employee Services, Year End Forms, Azure, Payroll, Customer Support and Sales, Data Synchronization Services, On Premise Products.