Payroll Service
Incident Report for Greenshades Online
Resolved
The issue has been resolved and all services are online and stable.
Posted Jul 14, 2022 - 20:24 EDT
Monitoring
A fix has been implemented and we are monitoring to ensure services are stable.
Posted Jul 14, 2022 - 18:23 EDT
Investigating
We are currently experiencing issues with our Payroll product. We are investigating the issue and hope to have service restored soon.
Posted Jul 14, 2022 - 17:39 EDT
This incident affected: Payroll.