Microsoft has fixed their hosting service issue. As mentioned in our prior update from ~1hour ago, Greenshades had already switched to secondary systems and all business critical services were fully operational. We are continuing to monitor Microsoft services to ensure operations remain stable.
Posted Feb 25, 2025 - 14:01 EST
Update
We are continuing to monitor for any further issues.
Posted Feb 25, 2025 - 13:02 EST
Update
Microsoft is experiencing downtime with some of their hosting services in at least US East, with a wide impact across Microsoft customers. Greenshades has failed over to a different service, and full uptime has currently been restored. We are closely monitoring, as there may be further disruptions due to the Azure difficulties.
Posted Feb 25, 2025 - 12:56 EST
Monitoring
Microsoft appears to be experiencing an error with some of their hosting services in US East, with a wide impact across Microsoft customers.
Greenshades has failed over to a different service, and full uptime has currently been restored. We are closely monitoring, as there may be further disruptions due to the Azure difficulties.
Posted Feb 25, 2025 - 12:56 EST
Investigating
We are currently experiencing intermittent connectivity issues with Greenshades Online and related services, causing website instability. Our team is actively investigating the issue and has opened a critical case with Microsoft to resolve this as quickly as possible.
We apologize for any inconvenience this may cause and appreciate your patience. Further updates will be provided as soon as more information becomes available.
Thank you for your understanding.
Posted Feb 25, 2025 - 12:42 EST
This incident affected: Single Sign On, Tax Service, Employee Services, Year End Forms, Azure, Payroll, and Data Synchronization Services.